Go

Pour Over Kettle

FAQs

Frequently Asked Questions

KETTLE IS PLUGGED IN BUT THE SCREEN AND LIGHTS ARE NOT WORKING
The appliance needs waking up.

Press the Start/Stop Button to illuminate the Screen.

The Kettle has not been used for 10 minutes

Press the Start/Stop Button, it will illuminate. Press the button a second time to wake and illuminate the Screen.

The Kettle is not on the Power Base.

1. Return the Kettle to the Power Base to remove the dashes across the Screen.

2. Ensure the Kettle is correctly sat on the Power Base.

The Kettle may not be properly connected to the power supply or the fuse may have failed.

Check the plug is in the socket and the switch is turned on. Replace the fuse if necessary.

THE KETTLE DOES NOT HEAT WATER
Boil dry feature may have been activated. If the Kettle is accidentally switched on with no water inside, the boil-dry device will switch off the heating element to prevent damage to the Kettle.

Wait 10 seconds for the Kettle to reset. NOTE: if discolouration of the heating plates has occurred, this can be easily removed by descaling your Kettle.

WATER IS SPURTING OUT OF THE SPOUT
You may have over filled the Kettle

1. Only fill to the max mark (800ml).

2. Wait 10 seconds to allow the heated water to settle before pouring.

The Kettle may have descaling solution remaining inside the body

Follow the instructions from the cleaning & care section and rinse thoroughly.

MY KETTLE IS NOT SWITCHING OFF OR TAKING LONGER THAN USUAL TO HEAT
Limescale may have built up inside the Kettle

Descale your Kettle regularly (see cleaning & care).

Kettle may have been removed before reaching previous target temperature

Press Start/Stop Button to cancel the heating cycle.

MARKS HAVE APPEARED IN THE KETTLE
Small brown spots can build up inside the Kettle. This is not rust, small deposits of limescale that contain iron can build up inside the Kettle.

Descale regularly (see cleaning & care).

WATER DROPLETS COLLECT ON TOP OF THE POWER BASE
This is condensation and perfectly normal

Dry with non abrasive cloth.

WATER ISN’T FLOWING FROM THE SPOUT
The Spout has been blocked with a build-up of limescale

Descale regularly (see cleaning & care).

HEATED WATER IS THE WRONG TEMPERATURE
Limescale may have built up inside the Kettle

Descale your Kettle regularly (see cleaning & care).

The wrong temperature units have been selected

Press the Temperature Unit Button to toggle between temperature units. Screen will display unit selected.

THE KETTLE IS NOT BEEPING
The Kettle is muted

Press and hold the Temperature Unit Button for 3 seconds to unmute the Kettle.

HOLD TIMER IS NOT COUNTING DOWN
The Hold Button was pressed after target temperature has been reached

Ensure to press the Hold Button during the heating cycle, before reaching the target temperature.

WHAT IS THE WATTAGE?
The wattage is 1.2kW.