Go

XL1500 Food Processor

FAQs

Frequently Asked Questions

Check the power cord is securely attached to the back of the processor and the bowls and lid are locked in position.

Check the power cord is securely attached to the back of the processor and the bowls and lid are locked in position.

Why has the processor switched off whilst in use?

  • The motor may have overheated. To prevent damage, the unit will automatically cut all power. If this happens, turn switch to 'OFF', unplug and allow the unit to cool for approximately one hour. Once cool the overheat safety feature will reset and you can carry on using the processor.
  • Check the lid or large bowl has not become loose.

What if it doesn’t chop uniformly?

  • Blades or discs may not be attached properly.
  • You may be exerting too much force on the food while pushing down the feeder tube.

What if my egg whites won’t stiffen up?

  • You may not be using enough eggs (we recommend a minimum of two eggs).
  • You may be using the wrong accessory; for egg whites you need the E-disc and the large bowl.
  • You may not be whisking for long enough.
  • Your bowl must be completely clean and dry

What if the drive shaft is sticking or the motor is struggling to turn the mixture?

  • The mixture may be too dense, remove some of the mixture and process in batches.
  • Run the motor for no more than15 seconds allowing for a one minute pause between cycles. This allows the machine to cool down to room temperature before next use.
  • After five cycles the appliance should be cooled down to room temperature before the next use.