Go

Food Processor

FAQs

Frequently Asked Questions

Check the power cord is securely attached to the back of the processor and the bowls and lid are locked in position.

Check the power cord is securely attached to the back of the processor. Ensure the bowl and lid are locked in position. Check that the small bowl has properly located onto the medium bowl. If the bowls are not interlocking correctly, the lid will also not locate properly and the processor will not turn on.

Check that the lid or bowl has not unlocked which will automatically trigger the safety cut-out

Check that the lid or bowl has not unlocked which will automatically trigger the safety cut-out. If these are still properly locked, the power cut off may be due to the motor overheating. (To prevent damage, the unit will automatically cut all power).
If this happens, turn the food processor off, unplug it and allow it to cool for 1 hour. The overheat safety feature will then reset and the processor will be ready to use again.
 

The blades or discs may not be attached properly or you may be exerting too much force on the food whilst pushing it through the feeder tube.

The blades or discs may not be attached properly or you may be exerting too much force on the food whilst pushing it through the feeder tube.

You may not be using enough egg.

You may not be using enough egg. We recommend a minimum of two eggs when using the E-disc and the large bowl. Ensure that you whisk for long enough and that the bowl is completely dry before you start.